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Introduction

InDesign is a fantastically powerful tool for generating and organising publishing output that 
is completely wasted on ePUB development.  This is because the essential premise of an 
eBook is that the layout is fluid and controlled by the user and the device, not the publisher.

Having said that, InDesign has its benefits, particularly when dealing with extensively text 
documents, ie the more traditional book or longer format document.  This article covers some 
of the basic skills uncovered when toying with this powerful application.  It is by no means an 
Indesign user guide, but enough to get you publishing.

Which version?

This document, and my InDesign efforts, have centred on CS5.  ePUB support has been 
available since CS3 but most reviews state iit only got serious from CS4.

Since this article is only about the basics of InDesign it should be applicable to both CS4 and 
CS5.



How Indesign organises your work

The basic building block in Indesign is a document.  Each time you create one you specify 
the page layout, then add your content (and extra pages as needed).  You can then publish in 
all formats, including ePUB.

Optionally you can collect documents into a single book.  In each book you specify the order 
that documents present in, and choose which document contains the “master” styles to be 
enforced across all the other documents.  Indesign takes care of applying those styles, mak-
ing sure page numbers run across all documents, etc.

For ePUBs you can publish from inDesign at the document or book level.  So there’s no real 
reason to go the book route (what do you care about running page numbers?).  The only 
real benefit is if you publish a book as an ePUB you get a table of contents that matches the 
document set it contains.  Plus, if your content is long, it does give you more manageable 
chunks to work with.



Creating documents and books

To create a document, simply select File > New > Document.  You’ll then get a dialog that 
has little bearing on any aspect of ePUB development:

As a result I recommend you ignore most if it.  Pick an A4 or A5 page layout for print so you 
just get some room to work without too many page breaks.

To create a book, select File > New > Book.  And then choose where to save it.

Once saved, what you’ve got is an empty book. 

To populate your book you then add your documents.  In the book panel, click the plus (+) 
button.  Then select the document(s) you want to include in your book.  Once selected they’ll 



be listed in the order added; you can drag and drop to set the required order.

The book panel will list all the documents in your book, and will automatically calculate the 
page numbers across all the content.  It also shows (by small icon on LHS) which document 
is picked as the master for your styles: more on that later.



Adding content to documents

Indesign gives you an extensive toolbar to add and manipulate content.  However if working 
mainly with text we only need a few.  And the real technique (and power of Indesign) is being 
able to add multiple pages of content in one go.

Now there is probably a better way to do this, but this worked for me.

(1) Save your required content into a text file.  It’s easy to export most documents into text.

(2) Open the document that the content is to be included in.  

(3) Select File > Place

(4) In the dialog that appears, select your file, but make sure you have selected the Show 
Import Options checkbox.

(5) In the Import options checkbox, make sure you pick options for extra carriage returns that 
match the format of your text import.  By default I’d always choose to remove returns at end 
of every line.  Also check the encoding matches the original.



(6) Click OK to import your content.  You’ll get a floating cursor thingie you can use to drop 
your content into your document. Now here’s the clever part: press and hold Shift and then 
click in the top left corner of your page.  

Clicking normally creates a text frame on the current page and puts your content intto it.  But 
if you press Shift first the icon turns to that snake thing above, and then InDesign will not only 
create the current page, but will create as many pages are needed to present all your con-
tent.

Story Editor

If you need to quickly review your content then use the Story Editor (Edit > Edit in Story Edi-
tor).  This gives a plain text view of all your content, allowing you to quickly scroll and edit 
without being distracted by styles and page breaks.  



This is an excellent tool for fixing up unwanted paragraph breaks, repeated footer text in-
cluded in the body, etc.  You can also use it as a quick way to run through content and apply 
styles - which we’ll describe next.



Applying styles to documents and books

By default all your content will come in as “Basic Paragraph” style.  You can view the avail-
able styles in the Paragraph Styles pane (if not visible choose Window > Styles > Paragraph 
Styles).

To add a style click the small add icon at the bottom of the pane.  You’ll then get an exten-
sive dialog to tweak to your heart’s content.  InDesign does a decent job of converting your 
request to CSS when exporting the ePUB; just avoid settings around pagination (eg “start on 
next odd page”) as these are meaningless in electronic land.

To apply a defined style to content simply click your cursor in the paragraph and then select 
the required style from the list.  You can do this in both the document window and the story 
editor window.

If using a book, setup all your required styles in one document.   And then use the book fea-
tures to apply those same styles across all documents in the book.

1. In the book panel ensure the document with the required/master styles is selected as the 
style source.  It should have the boxy icon appearing in the left column in the book pane.

2. Click the synchronise button (looks like two arrows attacking each other) at the bottom of 
the book pane.



Once synchronised, all the styles in your master document will now be updated in the current 
document.  You can then apply them to your content.  If already applied and you’ve made 
changes to the style, those changes will be automatically applied.

What about character styles?

This topic has spoken mainly of paragraph styles as that it was your ePUB will predominantly 
consist of.  Although even saying that I’ve yet to push much beyond half a dozen different 
styles.

Character styles work in exactly the same manner as paragraph styles, just with a few differ-
ent configuration options.  With characters the default style is “None”.  Add/update additional 
styles beyond that within the character styles pane (Window > Styles > Character Styles).



Adding images

To add an image to a document you use the same Place menu option as for adding text.  The 
important point, however is to add the image within your text, not in a floating frame.

To add an image inline simply place your cursor where you want the image to appear (be 
thinking location in text - after this paragraph - not location on page).

Then choose File > Place and locate your image:

Once placed you may have resize to make it fit: Choose Object > Transform > Scale from the 
menu.

Image formats

Since ePUBs are essentially web pages, use images in the standard web formats (GIF, JPG, 
PNG, SVG).  I’m sure InDesign can manage converting other formats but why bother if you 
can the appropriate conversion beforehand.



Publishing your ePub

To publish a document as an ePUB select File > Export for ePUB:

To publish a book as an ePUB select Export Book to ePUB from the book panel menu:

Once selected you get a standard dialog, and most of the options you can leave with their 
current detaults.



The only item to check is the format (use XHTML).  

If you make it ot the advanced class then use the options for CSS to allow you to apply the 
same styles acros multiple books.  And there looks like some option for having a single docu-
ment generate multiple chapters in your eBook.  Again. put that in the advanced course.



What next?

Once your ePUB is published open it in your required device and test.  If there are any issues 
return to InDesign to fix up and re-pubilsh.  A moment’s work.

If there are some fixes that are beyond InDesign then you’ll be pleased to know InDesign 
generates some of the cleanest XHTML I’ve seen in a long time.  If needing to go “under the 
hood” you’ll have no problem figuring it out.

Audio/Video

Other than minor tweaks to styles, the only ePUB changes I regularly make directly in the 
code are to add audio or video.  I’m sure you can probably import such content directly in 
InDesign but I find cutting&pasting boilterplate XHTML a lot simpler.



Conclusion

This article demonstrates the basic skills needed to generate an ePUB using InDesign.    

As you can see, publishing an ePUB using Indesign is a little like using an aircraft carrier as a 
harbour ferry.  Sure it will get you there but you’re not really using its full potential.  However 
it’s strengths in manipulating large text elements  make it a valuable publishing tool to have in 
your toolkit.



References & Resources

Adobe websites

The Adobe official website is.  Plenty of resources here, although most of the good stuff you 
can access directly from within InDesign.

http://www.adobe.com/products/indesign/epub/howto/ - collection of authoring guides for 
ePUBs.  Written for CS4 but mostly applicable for CS5 also.

•	 How to export for ePUB from InDesign

•	 Common questions about exporting EPUB files from InDesign

•	 Working with images in InDesign for export to EPUB

http://www.adobe.com/products/creativesuite/design/crossmedia_resources/ebooks_soft-
ware.html - includes some more resources, including videos of the basics.  Also of interest 
here is a topic on how to add the richer, interactive content (video, etc) directly in your publi-
cation.

Finally try the official blog.  Search on ePUB to see what’s been published:

http://blogs.adobe.com/digitalpublishing/?s=epub

Other websites

http://threepress.org/ - is always a useful site for thoughts on ePUB, not just via InDesign.  
For example here’s a great atrticle that explains all those ePUB publishing options I said you 
did not have to worry about.

http://blog.threepress.org/2009/11/23/choosing-indesign-epub-output-options/

http://www.pigsgourdsandwikis.com/ - is another great ePUB resource; so good she wrote 
the book on them.  For example, here’s her list of 22 reasons why you need to edit the ePUB 
source after InDesign finishes its publication:

http://www.pigsgourdsandwikis.com/2010/09/why-i-crack-open-indesign-epubs.html

As a final suggestion, here’s an interesting artcle on the process of converting a regular book 
to an eBook.  Less about the technical aspects, but about the suggested ways to adjust con-
tent and layout to respect the new approach.

http://henrymelton.blogspot.com/2010/03/converting-novel-from-indesign-to-epub.html

Video

Follow the Adobe links above for access to a series of official videos.  There’s also a vast col-
lection of quick reference video content on Youtube.  Just search for the topic you’re after.

Finally I’d also recommend the Instant InDesign prodcast (http://www.instantindesign.com/).  
Check out episodes 10 and 11 that dealt specifically with ePUBs.

http://www.adobe.com/products/indesign/epub/howto/
http://www.adobe.com/products/creativesuite/design/crossmedia_resources/ebooks_software.html
http://www.adobe.com/products/creativesuite/design/crossmedia_resources/ebooks_software.html
http://blogs.adobe.com/digitalpublishing/?s=epub 
http://threepress.org/
http://blog.threepress.org/2009/11/23/choosing-indesign-epub-output-options/
http://www.pigsgourdsandwikis.com/
http://www.pigsgourdsandwikis.com/2010/09/why-i-crack-open-indesign-epubs.html 
http://henrymelton.blogspot.com/2010/03/converting-novel-from-indesign-to-epub.html
http://www.instantindesign.com/
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