UPK simulations not working in LMS package? Check SCORM version

There are probably a million reasons why UPK does not work when published on your LMS. This may help resolve one of them.

Just created a LMS package without issue. But when publishing on our LMS (we’re using Oracle iLearn) the module would work fine until I try to run one of the simulations. After clicking “See It”, “Try it” or “Know It”, nothing would happen.

Turns out the reason why not was because I’d built the package with the wrong version of SCORM. When publishing (and SCORM version is set when publishing, not as part of the UPK options), UPK defaults to SCORM version 1.3 (2004).

However our LMS is only at 1.2. So the reason why the simulations were not loaded was simply that the package and LMS could not communicate over progress/status.

Changing the SCORM version to 1.2 in UPK, and republishing the LMS package, resolved the issue. The package now presents, completes and tracks perfectly.

[Annoyingly, this setting is not saved so you have to remember to reset it each time you publish. Would be better as a global option - you listening Oracle?]

One thought on “UPK simulations not working in LMS package? Check SCORM version

  1. nilda

    La version que utilizo de UPK es la 11.1.0 y esta version publica el LMS junto con el player, lo que quisiera saber es si hay alguna opcion de solo publicar
    el LMS solo ,por favor si alguien tiene la respuesta hagamelo saber

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>